[Expat-discuss] Libtool versioning info bumped incorrectly in 2.0.0 ?

Max Bowsher maxb1 at ukf.net
Tue Jun 13 22:57:12 CEST 2006

I think that the libtool versioning info has been incorrectly bumped for

All expat 1.95.x releases have shipped with LIBCURRENT==LIBAGE, implying
that whilst APIs may have been added, anything linked against old 1.95.x
releases ought to be able to continue to work if the expat shared
library is replaced with a newer release.

The 2.0.0 tarball ships with LIBCURRENT=6 and LIBAGE=5. This implies
that binary compatibility with expat 1.95.1 and earlier has been
explicitly broken, whilst binary compatibility with expat 1.95.2 and
later is retained. This seems an unlikely situation - more likely,
someone forgot to increment LIBAGE.

Note that this has caused libtool to now build Linux shared libraries
with a SONAME of libexpat.so.1, not libexpat.so.0, meaning that any
application linked against a shared libexpat 1.95.x will NEED A REBUILD
to work against a shared libexpat 2.0.0.

What is the true situation?


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 188 bytes
Desc: OpenPGP digital signature
Url : http://mail.libexpat.org/pipermail/expat-discuss/attachments/20060613/68173a5a/attachment.pgp 

More information about the Expat-discuss mailing list